Array

Descripción y usos de metaetiquetas compatibles con X-UA

-

Durante muchos años, las versiones obsoletas del navegador Internet Explorer de Microsoft & amp; apos; s causaron dolores de cabeza a los diseñadores y desarrolladores de sitios web. La necesidad de crear archivos CSS para abordar específicamente esas versiones anteriores de IE es algo que muchos desarrolladores web de mucho tiempo pueden recordar. Afortunadamente, Las versiones más nuevas de IE, así como Microsoft & amp;apos;s nuevo navegador, Borde, son mucho más compatibles con los estándares web, y dado que esos nuevos navegadores de Microsoft son & amp;quot;de hoja perenne y amp;quot; en la forma en que se actualizan automáticamente a la última versión, Es poco probable que luchemos con versiones anticuadas de esta plataforma como lo hicimos en el pasado.& amp; amp; nbsp;

Illustration of 'e' symbol and arrow sign
Illustration of 'e' symbol and arrow sign
& lt; / img & gt ;
Ivary / Getty Images

Para la mayoría de los diseñadores web, los avances del navegador de Microsoft y amp; apos; s significan que ya no tenemos que enfrentar los desafíos que la versión anterior de IE nos presentó en el pasado. Algunos de nosotros, sin embargo, no somos tan afortunados. Si un sitio que está administrando todavía incluye una cantidad considerable de visitantes de una versión IE anterior, o si está trabajando en recursos internos, como una intranet, para una empresa que está utilizando una de estas versiones anteriores de IE por alguna razón, entonces deberá continuar probando estos navegadores, a pesar de que eso está desactualizado. Una forma de hacerlo es mediante el uso del modo compatible con X-UA.

Video destacado

X-UA-Compatible es una metaetiqueta de modo de documento que permite a los autores web elegir a qué versión de Internet Explorer se debe representar la página. Internet Explorer 8 lo utiliza para especificar si una página debe representarse como IE 7 (vista de compatibilidad) o IE 8 (vista de estándares).

Tenga en cuenta que con Internet Explorer 11, los modos de documento han quedado en desuso y amp; # x2014; ya no se usan. IE11 ha actualizado el soporte para estándares web que causaron problemas con sitios web más antiguos.

Para hacer esto, especifique el agente de usuario y la versión que se utilizará en el contenido de la etiqueta:

Las opciones que tiene para el contenido son:

  • & lt; pre & gt; & amp; quot; IE = 5 & amp; quot; & lt; / pre & gt ;
  • & lt; pre & gt; & amp; quot; IE = EmulateIE7 & amp; quot; & lt; / pre & gt ;
  • & lt; pre & gt; & amp; quot; IE = 7 & amp; quot; & lt; / pre & gt ;
  • & lt; pre & gt; & amp; quot; IE = EmulateIE8 & amp; quot; & lt; / pre & gt ;
  • & lt; pre & gt; & amp; quot; IE = 8 & amp; quot; & lt; / pre & gt ;
  • & lt; pre & gt; & amp; quot; IE = EmulateIE9 & amp; quot; & lt; / pre & gt ;
  • & lt; pre & gt; & amp; quot; IE = 9 & amp; quot; & lt; / pre & gt ;
  • & lt; pre & gt; & amp; quot; IE = edge & amp; quot; & lt; / pre & gt ;

Emular la versión le dice al navegador que use el DOCTYPE para determinar cómo representar el contenido. las páginas sin un DOCTYPE se representarán en modo peculiar.

Si le dice que use la versión del navegador sin emular (es decir,., & amp; amp; nbsp;

) el navegador mostrará la página en modo estándar, ya sea que haya o no una declaración DOCTYPE.

le dice a Internet Explorer que use el modo más alto disponible para esa versión de IE. Internet Explorer 8 puede admitir hasta los modos IE8, IE9 puede admitir modos IE9, etc.

Tipo de etiqueta meta compatible con X-UA:

La metaetiqueta compatible con X-UA es una metaetiqueta http-equiv.

Formato de etiqueta meta compatible con X-UA:

Emule IE 7

Mostrar como IE 8 con o sin DOCTYPE

Modo Quirks (IE 5)

Usos recomendados de metaetiqueta compatible con X-UA:

Use la metaetiqueta compatible con X-UA en las páginas web donde sospeche que Internet Explorer 8 intentará representar la página en una vista incorrecta. Como cuando tiene un documento XHTML con una declaración XML. La declaración XML en la parte superior del documento arrojará la página a la vista de compatibilidad, pero la declaración DOCTYPE debería obligarla a presentarse en la vista de estándares.

Verificación de la realidad

Es poco probable que esté trabajando en sitios web que necesitan renderizar como IE 5, pero nunca se sabe. Todavía hay compañías que obligan a los empleados a usar versiones muy, muy antiguas de los navegadores para continuar usando el software heredado patentado que se desarrolló hace años para estos navegadores específicos. Para aquellos de nosotros en la industria web, la idea de usar un navegador como este parece una locura, pero imagine una empresa manufacturera que utiliza un programa de décadas para administrar el inventario en su taller. Sí, ciertamente hay plataformas modernas para hacer esto, pero han invertido en una de esas plataformas?& amp; amp; nbsp; Si su sistema actual no está roto, ¿por qué lo cambiarían??& amp; amp; nbsp; en muchos casos, ganaron & amp; apos; t, y encontrará que esta compañía obliga a los empleados a usar ese software y el navegador antiguo seguramente lo ejecutará. Improbable? Quizás, pero ciertamente es posible.& amp; amp; nbsp; si se encuentra con un problema como este, poder ejecutar un sitio en estos modos de documentos más antiguos puede terminar siendo exactamente lo que necesita.

& amp; # x203A; Informática

Dejar respuesta

Please enter your comment!
Please enter your name here

FOLLOW US

spot_img

Related Stories